Investigating
Incident Report for Nutrien Ag Solutions
Investigating
We are currently investigating an issue that may be affecting some of our services. Our engineering team is actively looking into the matter to identify the root cause and find a resolution. We apologize for any inconvenience this may cause and appreciate your patience.

We will provide updates as soon as we have more information. Thank you for your understanding.
Posted Dec 02, 2024 - 11:38 MST